August 06, 2020

Language:

CamSA20-44: ចំណុចខ្សោយធ្ងន់ធ្ងរនៅក្នុងកម្មវិធី Apache Tomcat

១. ព័ត៌មានទូទៅ

ភាពងាយ​រងគ្រោះ​ ឬចំណុចខ្សោយ​មាន​នៅ​ក្នុង​កម្មវិធី Apache Tomcat ចំណុចខ្សោយ​នេះ​ត្រូវ​បាន​កំណត់​លេខ​សម្គាល់​ (CVE-2020-13934) និង (CVE-2020-13935) មាន​កម្រិតសុវត្ថិភាព​ធ្ងន់ធ្ងរ​។ ចំណុចខ្សោយនេះកើតឡើង ដោយសារតែកំហុសឆ្គងនៅក្នុងកម្មវិធី Apache Tomcat HTTP/2 Denial of Service និង Apache Tomcat WebSocket Denial of Service អាចបណ្តាលអោយប្រព័ន្ធគាំងនៅពេលសំណើរជាច្រើនផ្ញើរចូលទៅលើម៉ាស៊ីនកុំព្យូទ័រមេលើសកម្រិត។

២. ផលិតផលដែលរងផលប៉ះពាល់

  • Apache Tomcat HTTP/2
    • Apache Tomcat 10.0.0-M1 ដែលមានកំណែទាបជាង 10.0.0-M6
    • Apache Tomcat 9.0.0.M5 ដែលមានកំណែទាបជាង 9.0.36
    • Apache Tomcat 8.5.1 ដែលមានកំណែទាបជាង 8.5.56 ·
  • Apache Tomcat WebSocket
    • Apache Tomcat 10.0.0-M1 ដែលមានកំណែទាបជាង 10.0.0-M6
    • Apache Tomcat 9.0.0.M1 ដែលមានកំណែទាបជាង 9.0.36
    • Apache Tomcat 8.5.0 ដែលមានកំណែទាបជាង 8.5.56
    • Apache Tomcat 7.0.27 ដែលមានកំណែទាបជាង 7.0.104

៣.ការណែនាំ

អ្នកប្រើប្រាស់ និងអភិបាលគ្រប់គ្រងត្រូវតែធ្វើបច្ចុប្បន្នភាពកម្មវិធីទៅកាន់កំណែថ្មីបំផុត (Latest version) នៃកម្មវិធីចុង ក្រោយបង្អស់។

  • Apache Tomcat HTTP/2
    • ដំឡើងកំណែទៅ Apache Tomcat 10.0.0-M7 ឬថ្មីជាងនេះ
    • ដំឡើងកំណែទៅ Apache Tomcat 9.0.37 ឬថ្មីជាងនេះ
    • ដំឡើងកំណែទៅ Apache Tomcat 8.5.57 ឬថ្មីជាងនេះ
  • Apache Tomcat WebSocket Denial of Service
    • ដំឡើងកំណែទៅ Apache Tomcat 10.0.0-M7 ឬថ្មីជាងនេះ
    • ដំឡើងកំណែទៅ Apache Tomcat 9.0.37 ឬថ្មីជាងនេះ
    • ដំឡើងកំណែទៅ Apache Tomcat 8.5.57 ឬថ្មីជាងនេះ

. ឯកសារពាក់ព័ន្ធ

 

***Disclaimer: CamCERT own some of the content. Our purpose is pure to help spread the awareness, tips or other information related to security to everyone. Even though every information is true, accurate, completed and appropriate, we make no responsibility nor warranty since everything could go wrong.